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Connecting to database files

Database Connections window

Figure 1 

The Database Connections window is used to connect the
software to the various database files that are to be used.

Connect the Database Manager module to the 
database

Database Manager must be open in the Database
Connections window.
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1 Go to File > Open.  

A File selection dialog box will open allowing you to browse
for and select the database of your choice.  

This dialog box is limited to the following database types: 

Access (*.mdb)
Excel (*.xls)
Dbase(*.dbf)

Note
A wizard is available to help you connect the software 
to the most frequently used databases. Choose the 
format option that matches your database format. If the 
format required is not available, do the following: 

1 Click Add... 

2  Select a database type from the list 

- or -

3  Select Others

4  Click Connection Setup

5  Click the Provider tab of the dialog box
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6  Select the required provider

7  Click Next >>

Note
The choice of provider changes according to the 
system’s type of database.

8  Click the ’...’ search button

9  Select a file 

10  Click Open
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11  Click OK

12  Click Next

13  Enter a name for the connection

14  Click Finish
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Note
You can repeat this procedure as often as necessary to 
obtain the required number of connections. 

Modify the database connection parameters
Database Manager must be open in the Database
Connections window. The required connection must be
selected. 

1 Click Edit

2  Make the required changes

Remove a connection
Database Manager must be open in the Database
Connections window. The required connection must be
selected. 

1 Click Remove
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Database file structure

Database Structure window

The Database Structure window is used to manage the
structure of the database file: to add, modify or delete tables/
fields etc.



Chapter 2 - 8 Database Manager - User manual
Choose a database from the list of connections
Database Manager must be open in the Database
Structure window.

1 Click on the Database drop-down list

2  Click on the data required

Choose a table in a database
Database Manager must be open in the Database
Structure window. 

1 Click on the Table drop-down list

2  Click on the data required

Add a table to the active database
Database Manager must be open in the Database
Structure window. 

1 Click Add table

2  Enter the name of the new table
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3  Click OK

You can also copy the structure of the table from a table that
already exists in the selected database. To do so: 

1 Tick the box next to Duplicate with

2  Click on the drop-down list

3  Click on the data required

4  Click OK

Delete a table in the active database
Database Manager must be open in the Database
Structure window. 

1 Click on the Table drop-down list

2  Click on the data required
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3  Click Delete table

View/hide active table’s data
Database Manager must be open in the Database
Structure window.

1 Click View data

Define a key field
Database Manager must be open in the Database
Structure window. 

1 Tick the box next to the required field

2  Click Apply

Define a field’s type of content
Database Manager must be open in the Database
Structure window. 

1 Click on the required field in the Type column

2  Click the drop-down list button

3  Click on the data required
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4  Click Apply

Define a field’s maximum size
Database Manager must be open in the Database
Structure window. 

1 Click on the required field in the Length column

2  Enter the value required

3  Click Apply

Allow an empty field
Database Manager must be open in the Database
Structure window. 

1 Tick the Allow Null box for the required field



Chapter 2 - 12 Database Manager - User manual
2  Click Apply
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Database contents

Edit Database window

The Edit Database window is used to manage the contents
of the database file: to add, modify or delete data.  

These actions depend on the type of database. Thus, Excel
file records cannot be modified. 
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Select records according to their content

Use the content 
of a field to find 
a record

Database Manager must be open in the Edit Database
window. 

1 Click the drop-down list button

2  Click on the data required

3  Click the data input field

4  Enter the value required in the data input field

Select all identical 
records

Database Manager must be open in the Edit Database
window and at least one record must have been found. 

1 Click the drop-down list button

2  Click on the data required

3  Click the data input field

4  Enter the data required in the data input field
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5  Click on the Select all button 

Note
You can also specify the filter by clicking on the ’Check 
case’ button. 

Select an 
identical record

Database Manager must be open in the Edit Database
window and at least one record must have been found.
There must be several identical contents in the search field. 

To select a record, use the search tool: click on 1 (First), 2
(Previous), 3 (Next) or 4 (Following). 

1 2 3 4
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Find a record according to its row in the table
Database Manager must be open in the Edit Database
window. 

1 Click the search tool’s data input field 

2  Enter the data required

Create a new record
Database Manager must be open in the Edit Database
window. 

1 Click on a field in the row marked with an asterisk 

2  Enter the values required in the corresponding fields 

3  Click Apply

Duplicate a record
Database Manager must be open in the Edit Database
window.

1 Click or double-click a row or a series of rows to highlight
the selected records

2  Right-Click to view the context-menu

3  Select Duplicate selected record(s)
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Modify a record
Database Manager must be open in the Edit Database
window. 

1 Click on the data you want to modifiy

2  Enter the data required

3  Click Apply

Sort a series of records by alphanumerical order
Database Manager must be open in the Edit Database
window. There must be at least two records in the table. 

1 Click on the name of the field required
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Note
To sort records in descending order, click on the same 
field again. 

Delete a record
Database Manager must be open in the Edit Database
window. 

1 Click the database cursor for the required field 

2  Right click the database cursor for the required field 

3  Click on ’Delete Record’ in the context menu
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Database queries

Database Query window

The Database Query window is used to create and apply
various filters. 

Add a query
Database Manager must be open at the Fields tab in the
Database Query window. 
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1 Click Add query

2  Enter a name for the query

3  Click OK

Select/deselect one or more fields
Database Manager must be open at the Fields tab in the
Database Query window.

To select or deselect one or more fields, click on the button
next to 1, 2, 3 or 4 in the navigation tool. 

  

1 Click Query

Modify the order of fields selected
Database Manager must be open at the Fields tab in the
Database Query window.

1 Click on the required field in the Ordered fields window

2  Click on the Up or Down arrow to reach the data required 

1
2
3
4
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3  Click Query

Note
For a better view of the query application, you can 
increase the size of the data display area by reducing 
the height of the Fields, Filter and SQL Query tabs. 

Create a filter using predefined data
Database Manager must be open at the Filter tab in the
Database Query window.

1 Click on the Add row button

2  Click in the Field field

3  Click the drop-down list button

4  Click on the data required
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5  Click in the Operator field

6  Click the drop-down list button

7  Click on the value required
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8  Click in the Value field

9  Enter the value required

10  Click Query

Table 1: Description of operator functions

Operator Lookup

= Equal to

<> Different from

> Greater than

>= Greater than or equal to

< Less than

<= Less than or equal to

NOT

IN

LIKE

NOT LIKE

BETWEEN

NOT BETWEEN
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Apply a logical operator to several filters
Database Manager must be open at the Filter tab in the
Database Query window. Several filters must exist. 

1 Click in the Logical field

2  Click the drop-down list button

3  Click on the data required

4  Click Query to apply and view the changes. 

Sort the list of filters
Database Manager must be open at the Filter tab in the
Database Query window. Several filters must exist.

1 Click on the database cursor for the required field

2  Click on the Up or Down arrow to reach the data required
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Remove a filter
Database Manager must be open at the Filter tab in the
Database Query window. At least one filter must exist. 

1 Click on the database cursor for the required field 

2  Click on the Remove row button

Modify a filter in SQL
Database Manager must be open at the SQL Query tab in
the Database Query window. At least one filter must exist.

1 Tick the box next to Modify the query in SQL language
to activate the SQL Query and make manual changes. 
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2  Click Query

Note
The filter can be created directly in SQL without having 
to use the Filter tab first. 

Choose an existing query in a database
Database Manager must be open in the Database Query
window.

1 Click on the Query drop-down list

2  Click on the data required

Note
The query selected can be modified later. 



C H A P T E R  5

Printing

The Print window

The Print window is used to select files for printing, to assign
printers and to define various parameters before printing is
launched.
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Display options
Database Manager must be open in the Print window.

1 Click Options

Preview the document
Database Manager must be open in the Print window.

1 Click Preview

Display the label design software
Database Manager must be open in the Print window.

1 Click Designer

Select a document to be printed

Create a new 
label template 
for printing

Database Manager must be open in the Print window.

1 Click on the Create labels wizard button

2  Follow the wizard’s instructions
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Note
Creating a label in relation to the database allows you to 
define exactly which elements are required to position 
each database field.

Select an 
existing label 
template

Database Manager must be open in the Print window.

1 Click on the Open an existing document button

2  Select a .lab file

3  Click OK

Note
The ’Field’ radio buttons in the ’Label name’ and ’Printer 
name’ groups of options allow you to choose the label 
or printer required, when the latter are defined in one of 
the fields of the active database.

Select a printer
Database Manager must be open in the Print window. A
label template must be selected.

1 Click on the Add or remove a printer button

2  Select the printer required

3  Click Validate

Note
The last printer used is selected by default.

Configure the selected printer
Database Manager must be open in the Print window. A
label template and printer must be selected.
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1 Click on the Printer settings button

2  Adjust the required settings

3  Click OK

Select records to be printed

Selecting 
records 
manually

Database Manager must be open in the Print window.

1 Tick the boxes next to the records required

Note
The height of the data display grid can be modified by 
dragging the top of the window.
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Selecting 
records 
automatically

Database Manager must be open in the Print window.

1 Click the drop-down list button

2  Click on the data required

3  Click on the data input field

4  Enter the data required

5  Click on the Select all button

6  Click on the Verify button

Configure the print media
Database Manager must be open in the Print window. A
document must be selected.

1 Click on the Page setup button
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Display the selected printer’s properties
Database Manager must be open in the Print window.

1 Click on the Page setup button

2  Click Settings...

Define the number of printed pages according to a 
field

Database Manager must be open in the Print window and
a printer must be selected. Records to be printed must also
be selected.

1 Click on the Quantity column drop-down list

2  Select the data required

3  Click the selected data’s drop-down list button

4  Select the required value or enter a whole numeric value

Note
This option allows a selection of labels to be printed 
according to numeric values defined in specific fields. 
Different criteria can be set:

•  SERIALQTY: defines the number of times the label
series will be printed

•  LABELCPY: defines the number of times the label
selected will be printed

•  PAGECPY: defines the number of times the page of
labels will be printed
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Launch printing
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Click the Print records button

Launch printing 
manually each 
time

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Tick the box next to Display the print dialog box
between each record

2  Click the Print records button

Update variable with database
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Tick the box next to Update variable with database

2  Click the Print records button

Merge Database 
attached to 
document

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Tick the box next to Merge Database attached to
document

2  Click the Print records button
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Allow the 
database to be 
edited

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Tick the box next to Allow the database to be edited

2  Click the Print records button

Stop printing
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected. Printing must have already
been launched.

1 Click the Stop printing button

Refresh database view
Database Manager must be open in the Print window. A
label template and printer must be selected. At least one
record must also be selected.

1 Click the Refresh database button

Close a document
Database Manager must be open in the Print window. A
label template must be selected.

1 Click on the Documents drop-down list

2  Click on the data required

3  Click the Close current document button
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	2 Click on the data required
	3 Click the data input field
	4 Enter the value required in the data input field

	Select all identical records
	2 Click on the data required
	3 Click the data input field
	4 Enter the data required in the data input field
	5 Click on the Select all button

	You can also specify the filter by clicking on the ’Check case’ button.
	Select an identical record

	Find a record according to its row in the table
	2 Enter the data required

	Create a new record
	2 Enter the values required in the corresponding fields
	3 Click Apply

	Duplicate a record
	2 Right-Click to view the context-menu
	3 Select Duplicate selected record(s)

	Modify a record
	2 Enter the data required
	3 Click Apply

	Sort a series of records by alphanumerical order
	To sort records in descending order, click on the same field again.

	Delete a record
	2 Right click the database cursor for the required field
	3 Click on ’Delete Record’ in the context menu
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	Database queries
	Database Query window
	Add a query
	2 Enter a name for the query
	3 Click OK

	Select/deselect one or more fields
	Modify the order of fields selected
	2 Click on the Up or Down arrow to reach the data required
	3 Click Query
	For a better view of the query application, you can increase the size of the data display area by reducing the height of the Fields, Filter and SQL Query tabs.

	Create a filter using predefined data
	2 Click in the Field field
	3 Click the drop-down list button
	4 Click on the data required
	5 Click in the Operator field
	6 Click the drop-down list button
	7 Click on the value required
	Table 1: Description of operator functions

	8 Click in the Value field
	9 Enter the value required
	10 Click Query

	Apply a logical operator to several filters
	2 Click the drop-down list button
	3 Click on the data required
	4 Click Query to apply and view the changes.

	Sort the list of filters
	2 Click on the Up or Down arrow to reach the data required

	Remove a filter
	2 Click on the Remove row button

	Modify a filter in SQL
	2 Click Query
	The filter can be created directly in SQL without having to use the Filter tab first.

	Choose an existing query in a database
	2 Click on the data required
	The query selected can be modified later.
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	Printing
	The Print window
	Display options
	Preview the document
	Display the label design software
	Select a document to be printed
	Create a new label template for printing
	2 Follow the wizard’s instructions

	Creating a label in relation to the database allows you to define exactly which elements are required to position each database field.
	Select an existing label template
	2 Select a .lab file
	3 Click OK

	The ’Field’ radio buttons in the ’Label name’ and ’Printer name’ groups of options allow you to choose the label or printer required, when the latter are defined in one of the fields of the active database.

	Select a printer
	2 Select the printer required
	3 Click Validate
	The last printer used is selected by default.

	Configure the selected printer
	2 Adjust the required settings
	3 Click OK

	Select records to be printed
	Selecting records manually
	The height of the data display grid can be modified by dragging the top of the window.
	Selecting records automatically
	2 Click on the data required
	3 Click on the data input field
	4 Enter the data required
	5 Click on the Select all button
	6 Click on the Verify button


	Configure the print media
	Display the selected printer’s properties
	2 Click Settings...

	Define the number of printed pages according to a field
	2 Select the data required
	3 Click the selected data’s drop-down list button
	4 Select the required value or enter a whole numeric value
	This option allows a selection of labels to be printed according to numeric values defined in specific fields. Different criteria can be set:

	Launch printing
	Launch printing manually each time
	2 Click the Print records button


	Update variable with database
	2 Click the Print records button
	Merge Database attached to document
	2 Click the Print records button

	Allow the database to be edited
	2 Click the Print records button


	Stop printing
	Refresh database view
	Close a document
	2 Click on the data required
	3 Click the Close current document button
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